USDC Access - technical issues with a liquidity provider
Incident Report for Circle
Resolved
USDC Access is fully recovered now.
Posted Oct 14, 2024 - 22:36 UTC
Update
We are continuing to investigate this issue.
Posted Oct 14, 2024 - 16:59 UTC
Update
We are continuing to investigate this issue.
Posted Oct 14, 2024 - 16:57 UTC
Investigating
Buy/Sell USDC experience on USDC Access is experiencing technical difficulties and temporary delays in Brazil, Mexico and Argentina. We are currently investigating the cause and working to resolve the issue.
Posted Oct 14, 2024 - 16:57 UTC
This incident affected: USDC Access and 3rd Party Infrastructure & Systems.