Polygon Mainnet Performance Degradation

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 12:28 UTC

Update

We are continuing to investigate this issue.
Posted Jul 01, 2025 - 11:16 UTC

Investigating

The Polygon mainnet is currently experiencing a network-wide stall. Our team is actively working with the Polygon Foundation to resolve this issue.
Posted Jul 01, 2025 - 11:16 UTC
This incident affected: Circle - Cross-Chain Transfer Protocol (POLY - Cross-Chain Minting and Burning), 3rd Party Infrastructure & Systems, and USDC (USDC - POLY - Minting, USDC - POLY - Redeeming).