Testnet Faucet - ETH Sepolia unavailable
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 18:44 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 19, 2024 - 14:10 UTC
Investigating
The Circle Testnet Faucet is unavailable on ETH Sepolia, and other chains are operational.
Posted Jul 19, 2024 - 11:14 UTC
This incident affected: Circle - Testnet Faucet and 3rd Party Infrastructure & Systems.