Flow USDC - Mainnet Performance Degradation
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Jan 21, 2023 - 05:07 UTC
Update
We are seeing performance improvements to the Flow network and will continue to monitor for any issues.
Posted Jan 21, 2023 - 04:37 UTC
Investigating
We are currently experiencing performance degradation with the Flow network.
Posted Jan 21, 2023 - 03:10 UTC
This incident affected: USDC (USDC - FLOW - Minting, USDC - FLOW - Redeeming).