Unichain Sepolia testnet network issues

Incident Report for Circle

Resolved

The third party has resolved the incident.
Posted Mar 08, 2025 - 00:23 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 07, 2025 - 23:11 UTC

Identified

We are seeing unexpected network issues impacting Unichain Sepolia testnet, causing transaction delays or degraded performance. Our team is investigating the root cause and working to restore normal operation as soon as possible.
Posted Mar 07, 2025 - 23:03 UTC
This incident affected: 3rd Party Infrastructure & Systems.