usdc.com - performance degradation
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Aug 30, 2024 - 15:29 UTC
Identified
The USDC website (https://www.usdc.com) partially functions due to a problem with our CMS provider. We are monitoring the situation and will provide further information as it becomes available.
Posted Aug 30, 2024 - 12:23 UTC
This incident affected: Circle - Websites (usdc.com).