Programmable Wallets - Arbitrum and Polygon Degraded Performance / Delays

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 01:04 UTC

Update

We are continuing to investigate this issue.
Posted Mar 27, 2025 - 00:16 UTC

Investigating

We have identified an issue causing delays or degraded performance on Programmable Wallets Arbitrum and Polygon chains. Some customers may experience slower transaction confirmations or partial unavailability. Our team is investigating the root cause and working to restore normal operation as soon as possible.
Posted Mar 26, 2025 - 23:37 UTC
This incident affected: Web3 Services APIs (PW - Dev-Controlled Wallets - ARB - Balance APIs, PW - Dev-Controlled Wallets - ARB - Transaction Creation/Estimation APIs, PW - Dev-Controlled Wallets - MATIC - Balance APIs, PW - Dev-Controlled Wallets - MATIC - Transactions Creation/Estimation APIs, PW - User-Controlled Wallets - ARB - Balance APIs, PW - User-Controlled Wallets - ARB - Transactions Creation/Estimation APIs, PW - User-Controlled Wallets - MATIC - Balance APIs, PW - User-Controlled Wallets - MATIC - Transactions Creation/Estimation APIs, MW - ARB - Balance APIs, MW - MATIC - Balance APIs).