USDC on Base Delayed/Outage Mint/Burns/Sends

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 20:51 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 09, 2025 - 14:35 UTC

Identified

USDC mints, burns and sends on Base are delayed/outage due to network congestions.
Posted Apr 09, 2025 - 05:10 UTC

Investigating

USDC mints, burns and sends on Base are delayed due to network congestions. We are working on updates to improve the speed.
Posted Apr 09, 2025 - 04:23 UTC
This incident affected: USDC (USDC - BASE - Minting, USDC - BASE - Redeeming) and 3rd Party Infrastructure & Systems.