xReserve Stacks Testnet Delays

Incident Report for Circle

Resolved

This incident has been resolved.
Posted May 23, 2026 - 04:35 UTC

Investigating

xReserve on Stacks Testnet is degraded. Withdrawals may be temporarily delayed.
Posted May 22, 2026 - 18:26 UTC
This incident affected: Circle xReserve APIs (Circle xReserve - Stacks - Testnet) and 3rd Party Infrastructure & Systems.