CCTP on XDC maintenance

Incident Report for Circle

Resolved

Circle has temporarily paused attestations for USDC burns on XDC via Circle's Cross-Chain Transfer Protocol (CCTP) as part of maintenance to CCTP on XDC
Posted May 20, 2026 - 12:19 UTC

Identified

Circle has temporarily paused attestations for USDC burns on XDC via Circle's Cross-Chain Transfer Protocol (CCTP) as part of maintenance to CCTP on XDC
Posted May 20, 2026 - 11:27 UTC