USDC Algorand - Delayed mints and burns

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 00:37 UTC

Investigating

USDC mints and burns on Algorand are delayed due to network issues. We are currently investigating the cause.
Posted Feb 19, 2025 - 23:46 UTC