A fix has been implemented and we are monitoring the results.
Posted May 05, 2025 - 16:38 UTC
Update
We are continuing to investigate this issue.
Posted May 05, 2025 - 16:38 UTC
Investigating
Sandbox USDC transactions on Arbitrum testnet are experiencing technical difficulties and temporary delays. We are currently investigating the cause and working to resolve the issue.
Posted May 05, 2025 - 16:12 UTC
This incident affected: Circle - Testnet Faucet (Public Faucet – ARB Sepolia), Circle Mint (Circle Mint - Sandbox), and 3rd Party Infrastructure & Systems.