Circle Wallet Service Delays/Degraded Performance

Incident Report for Circle

Resolved

The issue has been resolved.
Posted Nov 06, 2025 - 21:15 UTC

Update

We have identified an issue causing delays or degraded performance on Circle Wallet Service. Some customers may experience slower transaction confirmations or partial unavailability. Our team is applying the fix to restore normal operation as soon as possible.
Posted Nov 06, 2025 - 17:57 UTC

Update

We’ve identified the cause of the downtime and are applying a fix. We’ll update again once service is confirmed stable.
Posted Nov 06, 2025 - 17:07 UTC

Identified

We’ve identified the cause of the downtime and are applying a fix. We’ll update again once service is confirmed stable.
Posted Nov 06, 2025 - 16:47 UTC
This incident affected: Web3 Services APIs (PW - Dev-Controlled Wallets - ARB - Balance APIs, PW - Dev-Controlled Wallets - ARB - Transaction Creation/Estimation APIs, PW - Dev-Controlled Wallets - APTOS - Balance APIs, PW - Dev-Controlled Wallets - APTOS - Transaction Creation/Estimation APIs, PW - Dev-Controlled Wallets - AVAX - Balance APIs, PW - Dev-Controlled Wallets - ARB - SEPOLIA - Balance APIs, PW - Dev-Controlled Wallets - ARB - SEPOLIA - Transaction Creation/Estimation APIs, PW - Dev-Controlled Wallets - APTOS - TESTNET - Balance APIs, PW - Dev-Controlled Wallets - APTOS - TESTNET - Transaction Creation/Estimation APIs, PW - Dev-Controlled Wallets - ARC - TESTNET - Balance APIs, PW - Dev-Controlled Wallets - ARC - TESTNET - Transaction Creation/Estimation APIs, PW - Dev-Controlled Wallets - AVAX - FUJI - Balance APIs, PW - Dev-Controlled Wallets - AVAX - FUJI - Transaction Creation/Estimation APIs).