usdc.com Unavailable On Some Mobile Devices

Incident Report for Circle

Resolved

Issue with usdc.com has been resolved
Posted Apr 10, 2025 - 15:24 UTC

Investigating

We are currently investigating an issue where some iOS devices may have issues connecting to usdc.com
Posted Apr 10, 2025 - 14:49 UTC
This incident affected: Circle Websites (Circle - USDC Ecosystem Website).