Transacting on Arbitrum Sepolia is not stable

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 12:01 UTC

Investigating

We are currently investigating this issue.
Posted Feb 24, 2025 - 10:51 UTC