HyperEVM testnet Network Issues

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 18:21 UTC

Monitoring

The issue has been resolved. We will continue to monitor performance to ensure ongoing stability.
Posted Apr 15, 2026 - 09:57 UTC

Investigating

HyperEVM testnet is currently stalled. We are investigating the situation.
Posted Apr 15, 2026 - 07:37 UTC
This incident affected: Circle Gateway (Circle Gateway: HyperEVM - Testnet).