USDC Faucet - ARB Sepolia unavailable

Incident Report for Circle

Resolved

The network issue has been resolved.
Posted Jan 02, 2025 - 16:39 UTC

Update

We are continuing to investigate this issue.
Posted Jan 02, 2025 - 15:39 UTC

Update

We are continuing to investigate this issue.
Posted Jan 02, 2025 - 15:38 UTC

Investigating

USDC mints and burns on ARB Sepolia are delayed due to network issues. We are currently investigating the cause.
Posted Jan 02, 2025 - 15:27 UTC