Polygon Finalized Block Issue

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 03:04 UTC

Investigating

--- Investigating
USDC mints and burns on Polygon are experiencing technical difficulties and temporary delays. We are currently investigating the cause and working to resolve the issue.
Posted Apr 29, 2026 - 16:01 UTC
This incident affected: Circle Gateway (Circle Gateway: Polygon - Mainnet), 3rd Party Infrastructure & Systems, Circle Cross-Chain Transfer Protocol (POLY - Cross-Chain Minting and Burning), and USDC (USDC - POLY - Minting, USDC - POLY - Redeeming).