Solana USDC - Solana Devnet Maintenance

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 17:30 UTC

Monitoring

The Solana Devnet is currently undergoing maintenance. The latest slot is stalled at 391,843,993, and no new blocks are being produced at this time. Our team is actively monitoring the situation and will provide updates as they become available.
Posted Jul 03, 2025 - 17:14 UTC