We are continuing to monitor for any further issues.
Posted Jul 30, 2025 - 22:00 UTC
Monitoring
We have identified the underlying network issues affecting the Polygon mainnet and implemented mitigation steps. While overall network performance has improved, some users may still experience delays in transaction processing or degraded throughput.
Posted Jul 30, 2025 - 17:00 UTC
Investigating
We are continuing to work on a fix for this issue.
Posted Jul 30, 2025 - 12:21 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 30, 2025 - 12:13 UTC
Identified
Polygon Mainnet stalled at block height 74,592,238, and we are awaiting a resolution from the Polygon team.
Posted Jul 30, 2025 - 12:07 UTC
Investigating
We are seeing unexpected network issues impacting Polygon mainnet, causing transaction delays or degraded performance. Our team is investigating the root cause and working to restore normal operation as soon as possible.