USDC on SUI Delayed mints and burns

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 23:08 UTC

Investigating

USDC mints and burns on SUI are experiencing technical difficulties and temporary delays. We are currently investigating the cause and working to resolve the issue.
Posted Apr 02, 2025 - 18:07 UTC
This incident affected: USDC (USDC - SUI - Minting, USDC - SUI - Redeeming).